TXTML

The markup language for Subversive (Mobile) Storytelling

installation : requirements


  • A *nix environment, including OS X

  • Permission to run cronjobs

  • PHP version 5.2.* or higher compiled with the IMAP, SimpleXML, and mysql modules enabled

    The TXTML-interpreter uses both commandline PHP, via cronjobs, and PHP as an Apache module or attached to some other webserver

  • MySQL 5.* or higher


Plus one (or more) of the following:

  • An IMAP email account

  • An account with an SMS aggregator that has an HTTP API

  • OS X, a Bluetooth-enabled phone, and BluePhoneElite 2

  • A PC, a phone connected via serial cable, and SMSlib



This package is highly dependent on the BH library which should be included in the distribution. The BH library needs to be in PHP's include path. Recommended PHP settings are included in the htaccess.smp.

introduction
installation
authoring txtml
definition
event handlers
flow control
conditions
variables
content
math
other
feeds
requestors
formats
admin interface
extending